読者です 読者をやめる 読者になる 読者になる

【技術】CCNP ROUTEを受験する人が覚えておきたいコマンド【試験に出る!】

そろそろシャドバやめて本気出す(シャドバやめるとは言っていない)

ルーティングプロトコル全般

# show ip interface brief:インターフェースとIPアドレスのサマリー情報
# show ip route:ルーティングテーブル
# show ip protocols:ルーティングプロトコルの各種設定

EIGRP関連

(config)# router eigrp <AS番号>:EIGRPプロセス起動
(config-router)# network <ネットワークアドレス> <ワイルドカードマスク>:EIGRPが起動するインターフェースの定義
(config-router)# maximum-paths <値>:同じ宛先に対して使用するルートの数
(config-router)# variance <倍率>:メトリックが<倍率>倍のルートまで使用する(不等コストロードバランシング)
(config-router)# passive-interface [default/<インターフェース>]:EIGRPによるアドバタイズが有効だが、Helloパケット、Updateパケットの送信が無効となる
(config-router)# [no] auto-summary:自動経路集約を有効/無効にする
(config-router)# eigrp stub [receive-only / connected / static / summary / redistributed]:EIGRPスタブの設定
(config-router)# redistribute static:デフォルトルート配布
(config-if)# ip summary-address eigrp <AS番号> <アドレス> <サブネットマスク>:インターフェースにて手動経路集約を設定
(config)# key chain <チェーン名>:キーチェーン作成
(config-keychain)# key <ID>:キーID作成
(config-keychain-key)# key-string <パスワード>:パスワード設定
(config-if)# ip authentication mode eigrp <AS番号> md5MD5認証有効化
(config-if)# ip authentication key-chain eigrp <AS番号> <チェーン名>:キーチェーン適用
# show ip eigrp neighbors [detail]:ネイバーテーブル
# show ip eigrp topology:トポロジテーブル
# show ip route [eigrp]:ルーティングテーブル
# show ip eigrp interfaces:EIGRPが起動しているインターフェースの設定

OSPF関連

(config)# router ospf <プロセスID>:OSPFプロセス起動
(config-router)# network <アドレス> <ワイルドカードマスク> area <エリアID>:OSPFが起動するインターフェースとエリアの定義
(config-router)# router-id <ルータID>:ルータIDの設定
(config-if)# ip ospf priority <値>:DR / BDR選出時のプライオリティ
(config-router)# area <通過エリア番号> virtual-link <対向のルータID>:仮想リンクの設定(エリアの指定、ルータIDの指定に注意!)
(config-router)# default-information originate:デフォルトルート配布
(config-router)# area <エリア番号> range <アドレス> <サブネットマスク>:ABR上でのアドレス集約
(config-router)# summary-address <アドレス> <サブネットマスク>:ASBR上でのアドレス集約
(config-router)# area <エリアID> stub:スタブエリアにする
(config-router)# area <エリアID> nssa:NSSAにする
# show ip ospf:OSPF全般の設定
# show ip ospf neighbor [detail]:ネイバーテーブル
# show ip ospf database:リンクステートデータベース
# show ip route [ospf]:ルーティングテーブル
# show ip ospf interface:OSPFが起動しているインターフェースの設定

ルート制御関連

(config)# router <再配布先プロトコル>
(config-router)# redistribute <再配布元プロトコル>:ルート再配布の設定(再配布元、先を間違えないように!
(config-router)# default-metric <値>:再配布時のシードメトリック設定
(config-router)# redistribute <プロトコル> metric <値>:プロトコルごとにシードメトリックを設定
(config-router)# redistribute <プロトコル> subnets:サブネット化されたルートの再配布
(config-router)# distribute-list <ACL番号> [in/out] <インターフェース>:インターフェースで送受信するルートのフィルタリング
(config-router)# distribute-list <ACL番号> out <再配布元プロトコル>:再配布されるルートのフィルタリング
(config)# ip prefix-list <リスト名> seq <シーケンス番号> [permit/deny] <アドレス>/<prefix長> ge <prefix長> le <prefix長>:プレフィックスリスト作成
(config-router) #distribute-list prefix <prefixリスト名> [in/out] [インターフェース/プロトコル]:配布リストにプレフィックスリストを指定する
(config-router)# area <OSPFエリアID> filter-list prefix <prefixリスト名> [in/out]:OSPFのABR上でのルートフィルタリング
(config)# route-map <マップ名> [permit/deny] <シーケンス番号>:ルートマップ作成
(config-route-map)# match <条件>:ルートマップの一致条件を指定
(config-route-map)# set <処理>:条件に一致した時の処理を指定
(config-router)# redistribute <プロトコル> route-map <マップ名>:再配布されるルートに対してルートマップを適用
(config-router)# distribute-list route-map <マップ名> [in/out]:配布リストにルートマップを適用
(config-if)# ip policy route-map <マップ名>:ポリシーベースルーティングの設定
# show route-map:作成したルートマップ
# show ip policy:ポリシーベースルーティングで使用されるルートマップ
# traceroute:パケットが通過するルートを追跡

BGP関連

(config)# router bgp <AS番号>:BGPプロセス起動
(config-router)# neighbor <IPアドレス> remote-as <AS番号>:BGPピアの設定
(config-router)# network <ネットワークアドレス> mask <サブネットマスク>:AS内ルートのアドバタイズ設定
(config-router)# aggregate-address <アドレス> <マスク>:ルート集約設定
(config-router)# neighbor <IPアドレス> next-hop-self:iBGPピアにアドバタイズするルートのNEXT_HOP属性を自身のIPに変更
(config-router)# neighbor <ピアグループ名> peer-group:ピアグループ作成
(config-router)# neighbor <IPアドレス> peer-group <ピアグループ名>:ネイバーへピアグループを適用
(config-router)# neighbor <IPアドレス> weight <値>:ネイバーに対しWEIGHT属性の値を設定
# show ip bgp neighbors:BGPネイバーの詳細情報
# show ip bgp summary:BGPネイバーテーブル
# show ip bgp:BGPテーブル
# show ip route [bgp]:ルーティングテーブル

IPv6関連

(config)# ipv6 unicast-routing:IPv6ルーティングを有効化
(config-if)# ipv6 address <アドレス>/<prefix長> [eui-64]:IPv6アドレスの割り当て
(config-if)# ipv6 nd ra interval [msec] <最大値> [最小値]:RA送信間隔設定
(config-if)# ipv6 nd ra lifetime <秒>:ルータライフタイムの設定
(config-if)# ipv6 nd ra supress [all]:RAの定期送信を停止
(config-if)# ipv6 nd router-preference [high / medium / low]
(config)# ipv6 route <宛先>/<prefix長> <ネクストホップ>:IPv6スタティックルート設定

RIPng関連

(config)# ipv6 router rip <タグ>:RIPngプロセス起動
(config-if)# ipv6 rip <タグ> enable:インターフェースで有効化
(config-rtr)# maximum-paths <最大パス数>:同じ宛先に対して使用するルートの数
(config-if)# ipv6 rip <タグ> default-information [originate/only]:指定インターフェースの向こうに対してデフォルトルート(のみ)をアドバタイズする
(config-rtr)# redistribute static:デフォルトルートの配布

OSPFv3関連

(config)# ipv6 router ospf <プロセスID>:OSPFv3プロセス起動
(config-rtr)# router-id <ルータID>:ルータID設定
(config-if)# ipv6 ospf <プロセスID> area <エリアID>:インターフェースで有効化し<エリアID>に所属させる
(config-rtr)# maximum-paths <値>:同じ宛先に対して使用するルートの数
(config-rtr)# area <エリアID> range <集約ルート>:ABRで集約ルートの設定

EIGRP for IPv6関連

(config)# ipv6 router eigrp <AS番号>:EIGRP for IPv6プロセス起動
(config-rtr)# router-id <ルータID>:ルータID設定
(config-if)# ipv6 eigrp <AS番号>:インターフェースで有効化
(config-if)# ipv6 summary-address eigrp <AS番号> <集約ルート>:手動集約ルートの設定